Web serveur local inaccessible de l'extérieur - Forum - Culture Informatique

Avatar

SVP pensez à vous inscrire
guest

sp_LogInOut Connexion sp_Registration S'inscrire sp_MemberList Membres :

S'inscrire | Mot-de-passe perdu ?
Recherche avancée

— Activité du forum —






— Correspond —





— Options du forum —





La longueur du mot recherché est au minimum de 3 caractères et au maximum de 84 caractères

sp_Feed Flux RSS du sujet sp_TopicIcon
Web serveur local inaccessible de l'extérieur
26 octobre 2018
12:10:12
Avatar
New Member
Members
Level 0
Nombre de messages du forum : 1
Membre depuis :
26 octobre 2018
sp_UserOfflineSmall Hors ligne

Bonjour,

 

J'ai un projet de web serveur que je souhaite hébergé chez moi pour mes besoins persos. J'ai opté pour un serveur NGINX installé sur ma carte Raspberry PI (RPI).

 

Je suis au tout début, c'est à dire que j'ai installé le serveur, je peux y accéder avec un PC de mon réseau local en entrant l'IP de ma RPI dans URL. Mon routeur (ou proxy si j'ai bien compris) est une Freebox révolution. A partir de l'interface de ma freebox, j'ai affecté un IP statique à ma carte RPI, donc pas de risque que le DHCP affecte un nouvel IP.

 

J'ai actuellement un serveur web qui est déjà hébergé au sein de mon réseau local sur une autre RPI. Ce serveur fonctionne bien car je l'ai placé dans la DMZ de ma Freebox. Donc le serveur répond au port 80 de ma Freebox.

 

Pour pouvoir accéder à mon nouveau serveur web, je crois donc nécessaire  (sauf erreur de ma part) d'ouvrir nouveau port sur me Freebox pour transmettre les requêtes du mon extérieur vers mon nouveau serveur web.

 

Pour se faire :

  • j'ai créé une redirection sur ma freebox en choisissant le port 153 à destination de l'IP statique de ma RPI
  • j'ai modifié sur le serveur block de mon serveur NGINX pour écouter sur le port 153

Une fois fait, il m'est impossible d'accéder à ce nouveau serveur :

  • depuis un PC de mon réseau local, même en tapant 192.168.0.99:153
  • ainsi que depuis mon smartphone (non connecté en WIFI) en tapant 82.251.242.82:153

Je suis débutant en réseau, je suis preneur de tout conseil, de tout complément d'information et bien sûr de solutions ! 

Merci,

28 octobre 2018
5:06:18
Avatar
Administrateur
Level 10
Nombre de messages du forum : 314
Membre depuis :
8 octobre 2012
sp_UserOfflineSmall Hors ligne

Salut,

pour commencer : vérifie la config de ton Rasp en testant l'adresse directement sur le Rasp et en utilisant l'adresse de loopback : 127.0.0.1:153

Il faut que cela fonctionne avant d'aller plus loin. 

Sinon, tu peux utiliser un logiciel comme Advanced Port Scanner de l'intérieur et de l'extérieur pour tester si les ports sont bien ouverts et accessibles. Déjà ça devrait permettre d'y voir un peu plus clair.

Fuseau horaire du forum :Europe/Paris

Nb max. d'utilisateurs en ligne : 202

Actuellement en ligne :
8 Invité(s)

Consultent cette page actuellement :
1 Invité(s)

Auteurs les plus actifs :

ghous: 71

minsk01: 42

sami: 20

erwin: 16

Arth: 16

Hervé: 15

kauchmi27: 15

jerotheren: 13

cind-48: 13

tilda: 12

Statistiques des membres :

Invités : 110

Membres : 1732

Modérateurs : 0

Administrateurs : 1

Statistiques du forum :

Groupes : 1

Forums : 4

Sujets : 212

Messages :978

Administrateurs : admin: 314

Partager cet article ...